1

Update: See my answer. TL;DR, just get an old computer if this is what you want to do.

However, if anyone does have a USB-IDE adapter which they confirmed to work with ATA Secure Erase, whether laptop or desktop I'd love to hear about it and please post below. What would also be helpful is a PATA-SATA adapter that supports ASE functions.

Ha, I found this one: http://www.datadev.com/hard-drive-eraser-data-security-secure-erase-overwrite-software-hammer.html

At four grand, a little on the pricey side :).

1
+50

I stepped on this problem some time ago when I tried arbitrary smartmontools commands and they refused to work on USB hard drive. After investigation of this issue it come out that not all USB to SATA/PATA adapters supports bypassing direct ATA commands to hard drive.

You need USB bridge that provides SAT (an ATA pass-through) commands.
Chipsets that support it: ASMedia, Initio, Oxford, newer JMicron-JM20329, JM20335-39, Prolific PL2507/3507 PL2571/2771/2773/2775 ,Sunplus SPIF215/6, SPIF225/6.
Jmicron, Prolific and Sunplus supports fully ATA pass-through.

Reference: https://www.smartmontools.org/wiki/USB

| improve this answer | |
  • @NeMo Unfortunately it isn't easy task to find such adapters, many shops don't providing info about USB bridge. I found the right one by going to 3 stores with laptop and tested them all until I found correct one. – Alex Mar 7 '17 at 12:59
  • What was the name of the model you bought? – Ne Mo Mar 7 '17 at 13:03
  • @NeMO It was noname box with Prolific 2773 chipset – Alex Mar 7 '17 at 13:07
  • Do you remember where you bought it from? – Ne Mo Mar 8 '17 at 10:43
  • @NeMo I found it in a small local computer shop when was on a business trip to Omaha. It funny enough that no one from big guys as Frys, Bestbuy stores haven't such things, at least at time I shopped. I suggest you to get some cheapest PC on craigslist.org (you can find it there for less than $30) that has PATA interface and hook your HDD directly to it, then run some live Linux CD and secure erase it. I keeping HP dc5100 that has PATA & SATA ports for the similar tasks – Alex Mar 8 '17 at 16:29
0

I am the OP: my advice to anyone with the same issue would be just get an old motherboard and do it.

I have a few hard drives, laptop and desktop IDE, which I would like to Secure Erase. I'm aware that other methods exist for removing the data, but this is the safest and most efficient, and it's the one I want to use.

I found someone else with the same problem here, and a reply said

It depends on the chips in the adapters (see hdparm docs). Mine don't support it, and the only one of them that I can warn you about is the Seagate desktop expansion drive, the others have no branding.

In man hdparm it says

hdparm provides a command line interface to various kernel interfaces supported by the Linux SATA/PATA/SAS "libata" subsystem and the older IDE driver subsystem. Many newer (2008 and later) USB drive enclosures now also support "SAT" (SCSI-ATA Command Translation) and therefore may also work with hdparm.

However, I bought one which is support to support SAT, and reflected on the word 'may'.

I checked out https://www.smartmontools.org/wiki/Supported_USB-Devices. This is a list of devices which support SCSI-ATA Command Translation. I got a Gembird AUSI01.

It... didn't work. Just said 'erase prepare: invalid argument.'

I checked the adapter via USBdeview. It's genunine: correct chipset and device ID. It was able to work with smartmontools commands that I tried. It just wouldn't do Secure Erase, despite reporting that the drive could do Secure Erase.

So, I give up. Unless you have an opportunity to test this before you buy it, don't. Just grab an old computer... these days people will give them away for free.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.