I don't know if this is the right place to post this, but I'm in urgent need of help. So, about 10 days ago, I bought a Gigabyte x570 Aorus Elite motherboard. I recently switched from my old MSI B450 Gaming Plus MAX. I have always had my RAM, Corsair Vengeance 4x8GB DDR4 3200MHz. Link: https://www.amazon.com/Corsair-Vengeance-3200MHz-Desktop-Memory/dp/B0143UM4TC/ref=mp_s_a_1_3? (Set of 2. Each is 2x8gb)

All of the ram was at 2666MHz before, on my old board, which worked in slots 1 through 4, and slots 2 and 4. Recently, after getting the correct bios for this new motherboard for my cpu, all of my ram still works, but when I insert them all, it only shows 16GB out of 32GB (if I'm lucky, otherwise it shows 8gb even with 2 sticks in), in both windows and the BIOS. But software like CPU-z shows all 32GB (and or 16gb) are in the system. For this x570 board, at least for mine, when each piece of ram is inserted in slot 1, they are all recognized as 8gb. Slots 1 and 2, show 16gb total. When inserted into slots 1 and 3, only slot 1 is recognized. When inserted into slots 2 and 4, only slot 2 is recognized. I've tried multiple combinations, placing each stick in place of another, and no progress has been made. The BIOS version I am currently on is named "F32". It is meant for the Ryzen 9 5900x, which is my cpu. I am not sure if it's the BIOS version that is preventing the computer from recognizing all 4 sticks of ram in each slot, because the motherboard supports dual channel ram. I've been trying to diagnose the problem, which ofc I've had no progress. I've gone to Reddit, YouTube, Facebook, Geek Squad, and Gigabyte support themselves (they have not responded back after 8 days) nobody has answers. I was thinking that you might be able to help diagnose the issue. I also have been using the manual for the motherboard, but it's not working even at the defaulted BIOS settings. (Resetting the CMOS battery to clear back to the original stock bios settings). If you have ave any ideas, they would be greatly appreciated! Thank you!!

Quick note: I have also tried every single BIOS version for my cpu, I've installed the chipset drivers, put windows on different hard drives/SSD's. No results. I have also reseated the ram multiple times, checked my cpu for bent pins (there are none gratefully), but nothing's working. I've also checked in the BIOS, and it SHOWS that the ram slots B1 and B2, have "no" ram in them, even though each stick is placed in nice and snug in their slots on the board.

Hopefully this is enough detail to go through, but if you need more, I can do my best to provide you with more information about the issue I am having. I am just really wanting this motherboard fixed as I really want my 32gb for the system to work.

Thank you in advance!!

  • Can you try filling up your RAM with chrome tabs past 16GB and see if it slows down?
    – Irsu85
    Nov 15, 2022 at 5:42
  • Irsu85, yeah, it doesn't work. I actually just returned the board this morning due to it failing so 😭 gotta wait till black Friday then I can build a new PC lol Nov 16, 2022 at 6:02


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.