2

My laptop only has WiFi connection, but I've been successfully using AX88179 (USB3.0 to 10/100/1000M Gigabit Ethernet Controller) for a few years now. Yet as soon as my Internet connection became higher than 100 Mbps, then it seems I hit Asix' limit.

I've trying asking here and was told it's probably because of the adapter (I've tried using both Cat5, Cat5e and Cat6 cables - the latter of which gave me 1 Gbps in another house).

I tried contacting Asix but they haven't even bothered to reply.

I therefore consider buying a new adapter, but the tricky part is my laptop only has 2 USB ports. One is USB 3.0 and the other is USB 2.0. If I understand correctly, only USB 3.0 can used to achieve 1 Gbps.

In other words, the adapter I need should also serve as a USB 3.0 hub so I'll be able to connect other devices in general and other USB 3.0 devices particularly.

Do you know of any such device, which company is reputable enough to ensure I get 1 Gbps plus has technical support that actually replies?

What I want is:

1 Gbps Ethernet speed

What I don't want and so far have is:

100 Mbps Ethernet speed

Currently using:

USB to Ethernet with hub adapter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.